Rust Audio

Cpal is dropping audio samples - any idea why?

On my MacBook Pro (mid-2012), I can see cpal dropping some audio samples while portaudio gets all of them. I don’t know whether I am doing something wrong, or if portaudio is covering up for some deficiency in CoreAudio. I opened an issue on the cpal GitHub repo, just in case someone can help. My main goal is to learn audio processing in Rust, so I am curious to know if something can be improved in cpal, or in my usage of it.

Please let me know any ideas for investigation.

Hi @debamitro , welcome to the forum!

I have no experience with cpal myself, but I’ve left a comment on the GitHub issue. I hope this helps to find what caused the problem.

Hi @PieterPenninckx , thanks for your reply. I have replied to your comment on the GitHub issue. For everyone else I am sharing the link to the gist which contains my code…

I finally figured out what was happening. I have tried to explain it in the github issue (which I closed now). I have also tried to explain my journey in two blog posts - part I and part II.